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BVS Projector User Manual  (PC software)  
 
BVS Projector is used to create a geo-coded map for the analysis of the collected 
data with BVS survey software, such as Forecaster and Drone.  
 
Getting started with BVS Projector 
To use the BVS Projector, a GPS unit or GoogleEarth is needed to provide the 
latitude and longitude of the points in the map. There are two ways to do the 
projection: 

1.  Take a GPS unit to the survey area and record latitude and longitude 
for more than 8 points and also record the location of the measurement 
points; or 

2. Open GoogleEarth. The latitude and longitude for any point can be 
seen.  

Note that the accuracy requirement for latitude and longitude in the projector 
program is very high. The accuracy threshold is 0.00001o in decimal degree . The 

points should be spread out in the map to improve the accuracy of  projection.  

 

Open a Map 
To begin using the BVS Projector, click on the  hotkey to load a map, which 
can be a bmp, dib, emf, gif,  ico, jpg, wmf, tif or tiff file. Then the map will be 
shown on the screen. To open a GEOTIFF file, just select the file and open it.  
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Converting a GEOTIFF File to a CPF or DPF File  
Click on the  hotkey to open the GEOTIFF file, select the file and open it.  Select 
“Output Geo-Map” off the File Manu to save it as a coyote projection file (CDF) 
or a drone projection file (DPF).  
 

Saving BVS Projector Workspace 
 
At anytime after the project has been created it can be saved to a file. The 
current settings including state of controls and graph (map, bitmap and points) 
are saved in a project file and can be recalled later. To save a project select 
Save or Save as… from the File menu or the  Hotkey from the Toolbar. If the 

project has previously been saved the Save option will overwrite the existing file while the 

Save as… will allow a new file name to be selected. 

 

 
 
 
Opening an Existing Project 

To open an existing Project select “Open” from the File menu or the  Hotkey 
from the Toolbar. A dialog box will appear to allow the selection of the project 
workspace file (*.pws).  
 
Opening a CPF Project 

To open a CPF file, select “Open” from the File menu or the  Hotkey from the 
Toolbar. A dialog box will appear, click on the down arrow and then select the 
“*.cpf”. All the CPF files in the current fold will be shown.   
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Opening a DPF Project 

To open a DPF file, select “Open” from the File menu or the  Hotkey from the 
Toolbar. A dialog box will appear, click on the down arrow and then select the 
“*.dpf”. All the DPF files in the current fold will be shown.   

 
 
Select  a  Map to  Show  
If a TIF or TIFF file has multiple maps, the  button will be enabled. Click on the  

button will pop up a dialog box to select the map to display.  

 

Saving Current  View as a  Bitmap  
The current view of the map (with the points) can be saved as a bitmap. Select 
Save as Bitmap... from the File menu. 
 
Printing 
The standard Windows printing selections Print, Print Preview and Print Setup 
are available from the File menu. 
Projection Light 
A projection light is used to show if the projection is successful. If it is 
successful, the light is green; if it is failed, the light is red. 
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Input Format Selection 
Input format can be selected in the format of decimal degree or  
Degree::Minute::Second. The default setting is decimal degree. To select the 
format use the  Hotkey located on the top toolbar. Left click on the hotkey and 
the format selection dialog box appears.  
 
 
 
 
 

 
 

 

Projection Light: 

Green Light: Successful Projection 

Red Light: Failed Projection 
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If  a decimal degree is selected, the input format will be 

 
If “Degree::Minute::Second” is selected, the input format will be 
 

 
 
 

Output a Geo-Coded Map 
After projection light becomes green, a geo-coded map can be output. Select 
“Output A  Gep-Map” from the File menu and then save it as a CPF file or a DPF 
file. If the projection light is red, the software is unable to output a geo-coded 
map. 
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Output Part of a Geo-Coded Map 
 
If the whole map is too large, for example, one geotiff file can cover a state in 
the United States. If only part of the map is desired to use, please use the button 

 to select the part from the map and then use the “Output A Geo-Map” key to 
output a CPF file or DPF file.  
 
 
Control Buttons in the Toolbar 
 

 

 

 

 

 

 
 
 
 
 
There are several hot keys available to change the zoom of the graph view. 
 

Button Name Description 

 Zoom In Tool After clicking this hot button, the 
cursor changes to a magnifying glass. 

 Zoom Out Tool After clicking this hot button, the 
cursor changes to a zoom-out glass. 

 Fit to Window Pressing this hot key fits the image to 
the current size of the graph window. 

 
Double Click on the point will show the latitude and longitude of the point.  
 
Measure Distance 
After projection light becomes green, the ruler  button is active. As mouse 
moves on the map, the latitude and longitude are shown. Left click and hold on 
the graph to start the measurement. As the mouse moves, distance is displayed 
in the lower right corner of the window.  
 

Open 

a map 

Open a 

File 

Save Work 

Space 

Input Format 

Option 

Input 

Point 

Show 

Point 

Move 

Point 

Delete 

Point 

Ruler 

Zoom 

In 

Zoom 

Out 

Fit in 

Window 

Select Part 

of Map 

Select 

Unit 

Select Image 

to Show 
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Input Po ints 
 
After a point with latitude and longitude is set, the software will compute the projection 
parameters. If the requirement for projection is not met, the projection light will be red. The 
points, which do not meet the projection requirement, will be shown on a Dialog. For the 
example shown below, the 6th point does not meet the requirement, where the error threshold 
is 0.036 second (0.00001 degree). Double click on the 6th point, check if the input latitude and 
longitude is right.  
 
Note: Please spread out the points in the map to get an accurately geo-coded map. If the 
points are within a small area in the map, it will be difficult to do the projection successfully 
for the whole map.  
 
 
 
 

 
 

 

 

 

 

 
 

Bad Point 
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Procedure for creating a BVS GPS Projection File 
  
1. Find the area of interest on GoogleEarth. 
 
2. Select Alt-Print Screen to copy the current screen to the clipboard. 
 
2a. Do not close GoogleEarth, you will need it later. 
  
3. Open MS Paint. 
 
4. Choose Edit/Paste. The screen shot is now in Paint. 
 
5. Use the crop tool (dashed rectangle) to select only the satellite image portion of the screenshot. 
 
6. Choose Edit/Copy. 
 
7. Choose File/New. Do not save the current image. 
 
8. Choose Edit/Paste. The satellite portion of the original is now in the new image. 
 
9. Save this image as a bitmap. 
  
10. Open up BVS GPS Projector. 
 
11. Choose File/New and select the bitmap. You will see a red circle in the upper-right hand corner, 
this tells you the file is not geo-coded as of yet. 
 
12. Choose "Input Options" from the iconic toolbar under the main menu. Set the resulting popup 
box to "degree:minute:second". 
 
12a. Leave BVS GPS Projector running. 
  
13. Go back to GoogleEarth. You will need the positions of at least 6 points on the map to create a 
valid projection in BVS Projector. 
 
14. Choose the pushpin icon "Add Placemark". 
 
15. Move the resulting pushpin to your first location. Write down the latitude and longitude of the 
location. 
 
NOTE: North is positive and South is negative. East is positive and West is negative. This is 
important when entering degrees in BVS Projector. 
  
16. Go to BVS Projector and click on the 'set points' icon. 
17. Click on the same location as you did on GoogleEarth. 
 
18. Enter the latitude and longitude that you wrote down, keeping in mind to put a negative sign in 
front of the degrees when needed. 
 
19. The point will be numerically marked. 
 
20. If a popup box stating that the projection is now valid appears, proceed to step 21. A green 
circle would now appear in the upper right corner. If not, repeat steps 14-20 until a valid projection 
is obtained. 
  
21. Save the resulting projection in BVS GPS Projector as a GEO-coded map. 
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Forecaster Analyzer User Manual 
 
Forecaster Analyzer is the analysis component of Forecaster software package 
for Coyote or Panther Receivers. It provides analysis of coverage, reliability, 
channel reuse and more. 
 
Getting started with Forecaster Analyzer 
 
Forecaster Analyzer uses a geo-coded map from the Projector and data files 
recorded with Coyote or Panther Receiver. Projector generates a Projection File 
(*cpf) that contains the map of the survey. Coyote or Panther Receiver produces 
a data log file (*.klf or *.plf)  that contains the collected data.  
 
The Forecaster is project based.  To begin using the Forecaster, a projection file 
is first generated (Please see the manual for Forecaster Projector).  Click on the 

 hotkey located in the toolbar near the top of the screen. When Panther is 
used to collect data in scan mode, please log data file in Fast mode first and 
then switch to Scan mode. The Projection File dialog box then appears. Open the 
projection file (map) you wish to use. BVS YellowJacket Drone Projection file 
(*.dpf) can also be used by Forecaster Analyzer.  
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Then the data log files must be loaded to create a project.  The Forecaster 
Analyzer can process multiple log files. To create a new project select “New 
Project” from the File menu or the  Hotkey from the Toolbar.  
 

 
 
The data log file selection dialog then appears. 

 
 
In the data log file selection dialog press the “Select” button and browse for the 
*.klf files you wish to work with.   
 
More files can be selected by clicking on the “Add” button. If  you wish to use 
two or more files that you have saved, the data in these files can be merged to 
process by checking the box before “Merge Data”.  If a file is added in by 
mistake, check the box before the file and then press the “Delete” button. All 
selected files will be deleted.  Click the “OK” button to load the data in the files.  
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Note that the “Merge File" means merging the data in the files in the process.  It does not 

mean that multiple files are merged into one file. 

 

Log File Truncation     
 
When a log file is stored in CF card, the size of the file is equal to that of CF 
card. Usually is it  much larger than the real size. When the file saved in a CF 
card is loaded to process, a dialog box will be popped up to ask if the file needs 
to be truncated to its real size.  
 

Saving a Forecaster Project File 
At anytime after a project has been created it can be saved to a file. The current 
settings including state of controls and graph (map, bitmap and analysis) are 
saved in a project file and can be recalled later. To save a project select Save or  

Save as… from the File menu or the  hotkey from the Toolbar. 
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If the project has previously been saved the Save option will overwrite the existing file while 

the Save as… will allow a new file name to be selected. 
 
Opening an Existing Forecaster Project 
To open an existing Forecaster Project select Open Existing Project from the File 

menu or the  Hotkey from the Toolbar. A  dialog box will appear to allow the 
selection of the project file (*.fws).  
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The Forecaster Analyzer screen is displayed in two sections.   
 
 
 
 
 
 
 

 
 
Metric Selection 
Metric information can be displayed in feet or meter.  The default setting is feet.  
To select the metric use the  Hotkey located on the top toolbar. Left click on 
the hotkey and the metric selection dialog box appears.  

 
 
 

The left pane of the display contains 
the Control Window used for 
Clustering Points, View Options, 
Channel Selection, and Reliability 
Analysis.  

The right pane contains 
the graph and the map 
from the Forecaster 
Projector. 
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Clustering Points 
After loading the log files, the interface for clustering points is shown. This is 
used to separate the points with the signals, which have the same frequency, but 
they are transmitted from different towers/antennas. The automatic clustering 
has been done before this interface is shown. To separate the points, click  
Hotkey, left click and hold on the graph to start the clustering.  As the mouse is 
up, the points within the rectangular will be grouped as shown in the list of 
survey channels.  To merge two groups (channels) with the same frequency, 
check the boxes before them and then click Button .  
 

When a channel is selected (the box is checked), the parameters and information 
for the antenna is shown. Please type in the information or parameters if  they 

are known. Press  to input the information. 
 

  
 
After (base station) antenna's position is input, the BS will be shown on the 
graph. To move the BS, click  , left click at the center of the BS icon, hold on 
the graph and move it to the correct location.  
 
After the clustering is finished, click . The software will proceed to the 
next step of post processing. 
 
Buttons in Control Window for  Clustering Points 
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Button Name Description 

 
GPS Status Show GPS status by black circles. 3D fix: No black circles; 

2D fix: small black circles; No fix: big black circles. 

 
Show/Hide 

Base Stations 
Show or Hide base stations on the map 

 
Y/X or Lat/Lon Y/X: Use real distance (feet or meter) in the axis 

Lat/Lon: Use Lat/Lon (decimal degree) in the axis 

 
Vertical Grid 

Lines 
Show vertical grid lines  

 
Horizontal 
Grid Lines 

Show horizontal grid lines 

 Input 
Parameters 

Input the parameters for base stations and antennas 

 Merge Groups Merge multiple groups (in the channel list) into one group 

 Finish 
Clustering 

Process the data after clustering 

 
 
Map Information 
Click on the “Map Info…” off the View menu and the information about the map 
will be shown. These values cannot be changed.   
 

 
 
With a projection file it shows the ranges in feet or meter, without a map it 
shows the ranges in latitude and longitude.  
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Change Base Station Icons 
 
Right click on the base station, a dialog to select base station image is shown. 
Click on the desired image, press “OK” Button.    
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Show Map Directions  
 

Press the  button, the map directions are shown.  
 

 
 
 
Buttons in the View Options 
 

 

 

 

 

 

Buttons Name Description 

 

Walk/Drive 

Path 

Show/Hide Walk/Drive Path 

 

Path Width Change the Width of Walk/Drive Path 

 

 

Plot RSSI along 
Path 

Plot the RSSI of Measurement Points along the Survey Path. 

 

GPS Status Show GPS status by black circles. 3D fix: No black circles; 
2D fix: small black circles; No fix: big black circles. 

 
Show/Hide Base 
Stations 

Show/Hide Base Stations on the Map 

 

Coordinates 

Selection 

Y/X: Use the real distance in the axis 
Lat/Lon: Use Lat/Lon (decimal degree) in the axis 

 

Horizontal Grid 
Lines 

Show/Hide Grid Lines in X (Lon) Direction 

 

 

Vertical Grid 
Lines 

Show/Hide Grid Lines in Y (Lat) Direction 

 

 
Number of Grid 

Lines 

Change the Number of Lines in the Grid 

 

Select CH(s) 

you want to 

work with 
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Plot RSSI  along Survey Path  

To plot the RSSI along the survey path, click on the  button and then select the 

channel. A colorful drive path is shown below. Since GPS data is updated every second, the 

software will first filter out the redundant data and then average the independent data in 

the second. Note this is different from the processing stages in Coyote Sieve. The range in 

the map is from 0 dBm to –120 dBm. To change the range of RSSI, please move the sliders 

above.  

 

 
 
 

Plot The Averaged RSSI  along Survey Path  
If the distance traveled in one second is less than 40 lambda, the software will find the data 

within 40 lambda and then do the weighting average. The data are obtained by averaging 

the samples within one second. To plot the averaged RSSI along the survey path, click on 

the  button and then select the channel. A colorful drive path is shown. If none of the 

channels is selected, a dialog will be popped up to ask for selecting channels. The range of 

RSSI can also be changed by moving the sliders above. 

 
 

Plot The Number of  Averaged Points along Survey Path  
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The number of the points, which are used for averaging, can also be plotted along the 

walk/drive path. Click on the  button under “Channel Selection and Analysis”. A 

dialog will be popped up to take the range for the numbers. 

 

Plot The Reliability of Averaged RSSI  along Survey Path  

To plot the reliability of averaged RSSI along the walk/drive path, click on the button  

under "Channel Selection and Analysis". A dialog will be popped up to take the range for 

the reliability. The default value of RSSI variation to calculate the reliability is 1dB. For 

example, if the reliability is 90%, it means that the possibility that the averaged RSSI is 

within ±  1dB of the real mean value is 90%.  The accuracy of the averaged RSSI to the real 

mean value increases with the reliability. Assuming the number of points is N, the reliability 

is p, the variation is , the equation to calculate the reliability is
1
 

 

=

=

x
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This figure showing the reliability of averaged data is show below.  

 

                                                
1
 Please refer to the book – “The Mobile Radio Propagation Channel”, David Parsons, John Wiley & Sons, New 

York, 1992.  
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Plot The Variation of  Averaged RSSI  along Survey Path  

To plot the averaged RSSI along the walk/drive path, click on the button  under 

"Channel Selection and Analysis". A dialog will be popped up to take the range for the 

variation. The default value of the reliability to calculate the reliability is 90%. The 

accuracy of the averaged RSSI to the real mean value decreases with an increasing 

variation. Assuming the number of points is N, the reliability is p, the variation is , the 

equation to calculate  is  

 

( )
2/

57.5
)(

1

N

perf
p =

 

Analyze Measurement Data Using Information Window 
 

 

The following figure shows the analysis of measurement data by using the information 

window. Click on the  hotkey and then move the mouse to the point to be analyzed. Stay 

at the point for a second and the information window will be shown. The information 

window in this figure shows that the averaged value at this point is –61 dB, which is 

averaged by 48 samples. The real mean value has 79% possibility within -61±1 dB. 

 

 



 24 

Channel Selection 
 
Select the channels or group of channels you wish to work with in the control 
window under “Channel Selection”.  The Channel Selection tool contains a list 
of all channel(s) that are present in the log files. Checking the box next to the 
frequency includes the channel(s) in the analysis. As the channel is selected, its 
coverage graph will be shown in the graph window.  

  

Color Selection  
 
The color indicator between the frequency and the check box has two functions:  
 

One is to select the color used to graph signal strength from that 
channel(s). To change the color for a selected channel(s) right click on the 
color indicator. A color selection dialog box will appear.  
 
The other is to select how channels are grouped for analysis. After 
checking the channel, the RF coverage of that channel will be shown if it is 
not in the Reliability Analysis mode. If it is in the Reliability mode the 
area with certain reliability is shown. Reliability Analysis is explained in 
the following section. There are two conditions the user can choose from 
as shown in the following table: 

 
Example Grouping Description 

Example Grouping Description 

 

Individual Each selected channel is graphed 
in its own color indicated by the 

color of the star. 

 

Group Selection The best coverage for all channels 
is shown using the group color. 

 
Range Control   
This feature allows the user to control how the signal strength is represented using a graph.  

The two sliders set the minimum and maximum values for the graphing range.  

 

  
 
Resolution Control 

 Resolution Control along X/Longitude direction 

 Resolution Control along Y/Latitude direction  

 

 

Use these sliders to control 

min. and max. settings. 

Use these sliders to 

change the values Use the “R” button to 

set the default resolution 
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The resolution control shows the size of the points calculated. Setting the control 
for low resolution will reduce the calculation time and decrease the resolution. 
The button  resets the control to a reasonable default setting.   
 
Plot the Contour 
 

The detailed analysis with contours can be obtained by pressing the  button. 

A dialog will be shown for the minimum and maximum values for contours.  

 

 
 

Either the signal strength or the number of channels (N) in the coverage area can be shown 

by clicking the  (signal strength) or the  (number of channels) button.  

 

Draw Contours 

 
The range of the power (or number of channels) is shown in the following range control 

diagram. Move the sliders on the range control by clicking and holding the sliders to the 

desired value and the contours for the two values will be displayed in the graph window.  

 
 

Reliability Analysis 
Reliability Analysis shows the radius, boundary reliability, cell reliability and power 

threshold of the channel(s).  The user can input numbers via the keyboard and calculate the 

coverage on both the map and in the control panel. 

 

Channel(s) selected for Reliability Analysis is done with the channel Selection List. After 

selecting the channel(s) use the buttons in the control pane to calculate reliability analysis.  

To do single channel analysis select "Single Analysis" and the last selected channel is 

analyzed. Click on the “Reliability Analysis” button and input Power Threshold and 

Radius. Click  and the boundary reliability for this channel is shown under "Bn. 

Reliability" and the cell reliability is also calculated and shown. The coverage of the last 
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selected channel with the radius is shown as a circle on the graph window.  The reliability 

represents the probability that the received signal's strength is larger than the threshold 

value. The boundary reliability stands for the probability of the signal received at the 

boundary (larger than the threshold); the cell reliability stands for the probability of the 

signal received at the circular area. On the other hand if power threshold and probability 

(boundary reliability) are known click  and the radius and cell reliability will be 

shown. If "Group Analysis" is selected then all the selected channels will be analyzed with 

the same input data. An example is shown below.  
 
Note: If  the “Reliability Analysis” is open then the software is set to this mode.  
To see the coverage of the selected channel(s) click the “Reliability Analysis” 
again to pull up the interface and close this mode.  
 

 

 

Enter one of the 

two variables 

Then click on 

one of these 

arrows to 

calculate 

Enter Power 

Threshold 

Boundary 

Reliability 
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Buttons Controlling the View 
There are several hot buttons available to control the graph view. 
 

Button Name Description 

 Zoom In Tool After clicking this hot button, the 
cursor changes to a magnifying glass. 

 Zoom Out Tool After clicking this hot button, the 
cursor changes to a zoom-out glass. 

 Fit to Window Pressing this hot key fits the image to 
the current size of the graph window. 

 
Fit to Map Show the graph image with the whole 

map. 

 Show Directions Show the directions of the view. 

 Show Map Show/Hide the map 

 Information Window Show information as mouse hovers 

 Legend Window Show legend for the graph 

 Move Base Station Move base stations on the map 

 Ruler Measure distance 

 KML report Create a KML report 

 
HTML report Create a HTML report 

 
Measuring Distances 
Distance measurements can be made on a graph by using the ruler tool. To measure 

distances use the  hotkey. Left click and hold on the graph to start the measurement. By 

releasing the button the distance is displayed by a distance dialog box.  
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Saving Coverage Graph 
The current coverage graph can be saved as a bitmap. Select Save Graph 
Image... from the File menu. 
 

 
 
 
 
 
Table View 
To view the data point in tabular form select Table Window from the Window 
menu. 
 

 
 
An example of a table view follows on the next page. 
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where 

Lon: Longitude; 
Lat: Latitude; 
GPS: 3D -> 3D fix, 2D –> 2D fix, 0 –> No fix; 
RSSI: received signal strength indicator; 
CH: Channel number; 
BAND: Channel carrier frequency; 

  
To save the table in a form that can be used by spreadsheet applications and 
other programs select Save Table as… from the File menu.  
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The save table options dialog then appears. 

 
 
The output is an ASCII file that can be customized for easier conversion to a 
specific program. 
 
Printing 
The standard Windows printing selections Print, Print Preview and Print Setup 
are available from the File menu. 
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KML Report 
Keyhole Markup Language (KML) files can be opened by Google Earth

TM
 and the current 

view will be shown on top of GoogleEarth. If no projection files (*.cpf or *.dpf) exist the 

Forecaster software can generate a KML file automatically to plot the graph on top of the 

map of GoogleEarth. To use this feature, press the  Hotkey. If the map is shown in the 

graph, click on the  Hotkey to enable the  Hotkey. Select a file name to store the 

file when the dialog box appears. Then select a folder to store the image and write down 

some notes or descriptions for this image, which will be shown in GoogleEarth.  

 

 

 

 

 

 

 

After creating a KML file right click on the file and select "GoogleEarth" to open it. Pull 

down the scroll button at "Places" to the bottom and check the box before the file name, the 

view will be shown on top of GoogleEarth and the transparency can also be adjusted by the 

underneath slider control. It can also be saved in "My Places".  
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HTML Report 
HyperText Markup Language (HTML) files can be opened by Internet Explorer and can 

contain formatted text and graphics. Forecaster Analyzer can create a HTML report that 

has the information about the data survey files, the selected channels, the coverage of signal 

power and number of channels per location.  

To use this feature select  Hotkey. Select a file name to store the file when the dialog 

box appears. A dialog box for HTML report options will be shown. If no “Plot Contour” is 

carried the button “Show Coverage” and “Show BS Overlap” will be disabled. 

  

 

 
 
If  “Show Selected Files” is checked a message box will appear asking if the 
selected files are to be displayed in the report.  If “No” is clicked then all the 
files will be displayed in the report.  
 
 

 
 

Then a dialog appears to take the notes for the selected file.  Enter the notes for the 

different files by clicking the “Prev” or “Next” buttons.  After entering the notes for all the 

files then click “OK”.  All notes will be stored and displayed in the report.  
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If “Show BS’s Information” is checked a message box will appear asking if only 
selected base stations are shown in the report.  If  “No” is selected then all of 
the base stations will be displayed in the report.  
 

 
 

 
 

 

 

Then a dialog box appears to take the parameters and notes for the selected base stations or 

channels. The parameters obtained at the interface for clustering points are shown here.  

Modify the parameters and notes for the different BSs by clicking the “Prev” or “Next” 

buttons. After entering the notes for all of the BSs click “OK”.  All notes will be stored and 

displayed in the report.  
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